ATI Sapphire x1650 Pro en Tiger / Leopard con QE y CI (MacLovin)

Noticias sobre apple,mac, osx, iphone,ipad,apple watch, juegos para mac y appletv

ATI Sapphire x1650 Pro en Tiger / Leopard con QE y CI (MacLovin)

By
miliucoLazarus Long

Mac Points: 18.376, Nivel: 14Subir Nivel: 53%, 1.274 MacPoints Actividad en Applesana: 0% Ingreso:mar 2006Ubicación:La Robla, León (ES) .:44

ATI Sapphire x1650 Pro en Tiger / Leopard con QE y CI (MacLovin)MacLovin tiene una guía, en forum.osx86scene.com, sobre cómo instalar las tarjetas gráficas de la serie ATI x1600 en Leopard, con el título:

"[Guide] ATI x1x00 Video Cards on Leopard, QE/CI Enabled"

En mi caso he probado a instalar una tarjeta ATI x1650 Pro con 256 MB de RAM, de la marca Sapphire en Tiger 10.4.11 y ha funcionado, consiguiendo aceleración gráfica y un buen funcionamiento, sin artefactos.

Como la guía de MacLovin está en inglés y es un poco larga, la resumo en base a mi experiencia personal por si a alguien con esta tarjeta o similar le pudiera servir. Aunque las instrucciones están muy detalladas, no es una guía para principiantes, se da por sentado que el usuario sabe activar root, editar extensiones, arrancar Darwin con modificadores -v (verbose) y -f (forzar la carga de extensiones), averiguar el ID de la tarjeta gráfica, etc.

Archivos necesarios

- ATIinject.kext (en la guía de MacLovin hay un enlace al archivo)

- ATIRadeonX1000.kext original (copiado de la carpeta Extensions o del DVD de Tiger)

Programas necesarios

- editor de archivos Info.plist (TextMate de Allan Odgaard, Propertylist Editor de XCode Tools de Apple, Textedit de OSX también funciona con muchos archivos plist, no con todos)

- 0xED de SuaveTech- editor hexadecimal

Paso 1: editar ATIinject.kext - Info.plist

- botón derecho sobre ATIinject.kext >> Mostrar contenido del paquete

- Contents >> Info.plist (abrir este archivo)

- buscar la sección que define el DeviceID de la tarjeta gráfica (en este ejemplo sería 71c1):

ATY,DeviceID
0x71c1

- las secciones comentadas a continuación pueden ser borradas:

ATY,FrameBufferOffset
0x00000080


ATY,IOSpaceOffset
0x00300000


ATY,VRAM,MemSize
0x00000100

- guardar el archivo y salir

Paso 2: editar ATIRadeonX1000 - Info.plist

- botón derecho sobre ATIRadeonX1000.kext >> Mostrar contenido del paquete

- Contents >> Info.plist (abrir este archivo)

- buscar la sección IOPCIMatch para añadir el DeviceID de la tarjeta gráfica, procurando conservar las entradas que ya existan y evitando duplicados (provocarían kernel panic al arrancar), añadiendo la nueva en el mismo formato que las otras, por ejemplo, con DeviceID 71c1 y VendorID 1002 (corresponde a ATI) la sección quedaría similar a ésta:

IOPCIMatch
0x71871002 0x71c11002 0x71c31002 0x72101002 0x71DE1002 0x71461002 0x71421002 0x71091002 0x71C51002 0x72401002 0x72491002 0x72911002

- guardar el archivo y salir

Paso 3: editar con 0xED el archivo binario ATIRadeonX1000

- este paso siempre ha de ir detrás del paso 2, si se modifica el archivo Info.plist de nuevo después de la modificación binaria con 0xED el PC no arrancaría por lo que la última modificación en ATIRadeonX1000.kext ha de ser la hexadecimal

- arrancar el programa 0xED >> File >> Open >> ATIRadeonX1000.kext >> Contents >> MacOS >> ATIRadeonX1000

- menú Edit >> Find >> Find

- buscar c071 para reemplazarlo por el DeviceID de la tarjeta gráfica pero invirtiendo las parejas, si el ID es 71c1 el reemplazo sería c171, se configura la búsqueda como "Search type=Hex" >> Replace all (en mi caso sólo se encontró 1 coincidencia pero en otros sistemas ese número puede variar)

- buscar 71c0 para reemplazarlo por el DeviceID de la tarjeta gráfica tal cual, si el ID es 71c1 el reemplazo sería 71c1, se configura la búsqueda como "Search type=Hex" >> Replace all (en mi caso se encontraron 3 coincidencias pero en otros sistemas ese número puede variar)

- menú File >> Save >> Exit

Paso 4: instalar archivos, limpiar cachés, reparar permisos y reiniciar

- borrar en System/Library/Caches la carpeta com.apple.kernelcaches

- borrar en System/Library los archivos Extensions.mkext y Extensions.kextcache

- borrar en System/Library/Extensions el archivo ATIRadeonx1000.kext (o renombrarlo a ATIRadeonx1000.kext.back) y cualquier archivo relacionado con la terjeta gráfica que se hubiese instalado anteriormente

- copiar los archivos modificados ATIinject.kext y ATIRadeonX1000.kext a System/Library/Extensions

- reparar permisos

- reiniciar >> pulsar F8 para que aparezca el menú de Darwin >> arrancar con -v -f

godisnotaliveLibrepensador

Ingreso:sep 2007Ubicación:Valencia .:14

SUPERTUTORIALLLLLL!!!!!!!!!!
Milliuco es para felicitarte, gracias.
Pero estoy pensando en pillar esta Sapphire pro 256Mb (la del enlace) y me gustaría que pudieras (tu o cualquier otro applesano crac) explicar la edición del kext ATIRadeonX2000.kext y todo el proceso en definitiva para las ati 2000. Aunque si lega el glorioso dia en que se me termine de bajar el kalyway 10.5.1 creo q hay cierta "posibilidad" de que funcionen unas cuantas tarjetas con él (mirad la imagen).

Gracias Milliuco xDD




VGA PCIE ATI HD 2600PRO 256MB SAPPHIRE

Fabricante Chip: ATI
Chip Grafico: Radeon HD 2600PRO
Memoria RAM: 256MB DDR2
PCI Express: x16
Interface de memoria: 128 bits
Nucleo grafico (Core): 600 MHz
Reloj de memoria: 800MHz
Pipelines: 4
DirectX: 10
Pixel Shader: 4.0
Conectores: DVI X2 / S-Video / Adaptador DVI a HDMI
Ventilador: similiucoLazarus Long

Mac Points: 18.376, Nivel: 14Subir Nivel: 53%, 1.274 MacPoints Actividad en Applesana: 0% Ingreso:mar 2006Ubicación:La Robla, León (ES) .:44

No he hecho nada con tarjetas como la que comentas, busca primero a ver si hay algo por ahí para tener más seguro que la puedas usar en OSx86. El que sea como las que llevan algunos Mac no lo garantiza, busca información.godisnotaliveLibrepensador

Ingreso:sep 2007Ubicación:Valencia .:14

Ya lo he hecho, y creo q si funcionará, hasta que no lo pruebe no quiero decir nada más...por si acaso xD
Pero ya lo he decidido, me la voy a pillar con una placa base Asus Commando o P5K-E/wifi-AP

Asus Commando:

P5K-E/wifi-AP:

jejejeje, q ganas teniagodisnotaliveLibrepensador

Ingreso:sep 2007Ubicación:Valencia .:14

Ah, y a ver como van con 10.5.1 y EFI, el kalyway se me acabara de bajar +/- mañana por la tarde!!
Ya contare en el hilo EFImiliucoLazarus Long

Mac Points: 18.376, Nivel: 14Subir Nivel: 53%, 1.274 MacPoints Actividad en Applesana: 0% Ingreso:mar 2006Ubicación:La Robla, León (ES) .:44

Son 2 placas excelentes, veo más probabilidades en la Commando, el audio parece Azalia, ¿no?, pero ¿y la red?

Echa un vistazo a ésta:



Socket 775 (C2D...)
Chipset Intel G965
SATA Chip Intel ICH8 Southbridge
Graphics Media Accelerator X3000
Sonido ADI 1988A
Realtek Gigabit Ethernet
etc...senhezsenhez

Ingreso:mar 2006 .:10

Hola amigo Miliuco

Este paquete de drivers hace exactamente eso

Drivers Series X1X Ati X1650 Pro PCiExpress 256MB

Sólo para Leopard e ID 71c1godisnotaliveLibrepensador

Ingreso:sep 2007Ubicación:Valencia .:14

Milliuco, sobre la placa, esta bien pero, yo lo que busco era una con chipset para Penryn, que si te pasas por la pagina de Apple veras el nuevo Mac Pro Penryn 8 cores Xeon de serie con 12Mb L2 y 1600Mhz FSB y por lo que no quedan dudas sobre incompatibilidades Mac-P35/X38-Penryn.
Mañana recojo la Asus P5K-E/wifi-ap, la grafica Sapphire 2600Pro 256Mb (el nuevo mac pro lleva la 2600xt) y 2 gb Ram DDR2 800Mhz kingston (a la velocidad de la Ram del nuevo Mac Pro) aunque creo q me acabare comprando unos modulos q he visto a 1066 Extreme Memory por 35€.
Por cierto en el hackintosh actual (el de la firma) ya tengo kalyway 10,5,1 EFIv8 i va absolutamente perfecto, me reconoció perfectamente el Audio Realtek, Red PCI Realtek, la GMA950 QE/CI,... el único problema es que en acerca de este mac dice que mis 2 modulos 1gb 667Mhz van a 333Mhz, alguien sabe xq puede pasar esto??

Gracias y pasaros por Apple, pues se han lucido bastante con el nuevo Mac Pro
godisnotaliveLibrepensador

Ingreso:sep 2007Ubicación:Valencia .:14

Estoy teniendo problemas con mi nueva placa P5K-E y la grafica Sapphire HD2600pro 256mb, al instalar el sistema no arranca ni en AHCI ni IDE estando la particion marcada activa, siendo una particion sola en el disco y solo ese disco conectado, y la grafica no tiene QE/CI con los drivers de Apple, los que hay en el wiki para Tiger solo me han ocasionado un panic.
Alguien puede pasar drivers para esta grafica por favor??
Estoy pensando en cambiar la placa por la comando y la grafica por una nVidia 7300gt point of view 512mb o una Ati x1600. Que opinais?
Necesito ayuda urgentemiliucoLazarus Long

Mac Points: 18.376, Nivel: 14Subir Nivel: 53%, 1.274 MacPoints Actividad en Applesana: 0% Ingreso:mar 2006Ubicación:La Robla, León (ES) .:44

Zhense: tengo guardado ese instalador de ATI 71c1 por si acaso más adelante pruebo Leopard, lo descargué desde la página en que MacLovin tiene sus instrucciones:

forum.osx86scene.com >> "[Guide] ATI x1x00 Video Cards on Leopard, QE/CI Enabled"

Tiene otros instaladores para otros DeviceID, todos son para Leopard, por éso en mi tutorial, que es para Tiger, recurro al método manual aunque en realidad lo que propongo en él equivale a lo que MacLovin prepara en su instalador por lo que supongo que funcionaría también en Tiger.miliucoLazarus Long

Mac Points: 18.376, Nivel: 14Subir Nivel: 53%, 1.274 MacPoints Actividad en Applesana: 0% Ingreso:mar 2006Ubicación:La Robla, León (ES) .:44

Godisnotalive: piensa en lo que traen los Mac, salvo algunos Mac Pro los demás usan gráficas de 256 MB de memoria, en caso de comprar una Geforce 7300GT, cógela de 256 MB para asegurar la compatibilidad.

En la sección de Hardware >> Tarjetas NVidia tengo un tema sobre una GeForce 7300GT de 256 MB de la marca Asus (modelo EN7300GT) y en él comento lo fácilmente que se instala con los drivers NVinject, sin tener que modificar kext ni escribir DeviceID, funcionando con QE + CI + resoluciones + rotación (pero no he conseguido la salida de doble monitor).godisnotaliveLibrepensador

Ingreso:sep 2007Ubicación:Valencia .:14

La placa P5K-E y la XFX 7300gt de 512mb que me compre se llevan como el culo. Estoy pensando en pillar la gigabyte que Juker puso en el wiki , que esta en APP por 90€ con una gigabyte x1650 o quedarme con mi 7300gt i continuar calentandome la cabeza. Que pensais?miliucoLazarus Long

Mac Points: 18.376, Nivel: 14Subir Nivel: 53%, 1.274 MacPoints Actividad en Applesana: 0% Ingreso:mar 2006Ubicación:La Robla, León (ES) .:44

La propuesta de Juker parece de lo más atractiva.juker12Juker

Mac Points: 56.158, Nivel: 24Subir Nivel: 73%, 1.292 MacPoints Actividad en Applesana: 71% Ingreso:mar 2006 .:98

godisnotalive de perdido al rio

Mira estaba yo por comprarme ya mismo la grafica de Miliuco en split por 100 euros las dos graficas

La Nvidia 7300 completamente compatible con Mac OS X Tiger y Leopard

Pero pense, mejor pillate la ATI Radeon HD 2600 XT de los nuevos Mac PRo e iMac 2007

Y hoy me tiro al rio, ni una cosa ni la otra, me pillo el mes que viene la Nvidia 8800

http://www.applesana.es/blog/1505/ki...-polemica.html

que va divina de muerte con los Kexts oficiales de Mac OS X 10.5.2 nativos, de 64 Bits como a mi me gusta y sin tocar por nadie

Esa grafica 8800 y lo que tengo ahora, un cohete nuclear

Comprar mi placa por la grafica no lo recomiendo, he tenido la developer con una GMA900 y es muy limitada.

La que trae mi placa de ahora es la GMA x3100 que no es la misma que la de los portatiles y he sudado tinta china para instalarla en un solo monitor.


Ademas, como integrada que es, pilla solo 64MB muy limitado, asi que lo dicho...grafica externa una 8800 nativa.godisnotaliveLibrepensador

Ingreso:sep 2007Ubicación:Valencia .:14

Juker pasate por aqui (Gigabyte GA-G33M-DS2R) y dime que te parece esta placa () es muy parecida a la tuya(red, audio, controladora de discos,..). Ok?
Oye cuando dices que las 8800 pillan bien los drivers de 10.5.2 te refieres a los del wiki? Cuando pruebes la grafica molaria que hicieras un post. Yo cuando consiga que la mia tenga QE/CI hare uno, parece un caso dificil...uff xDjuker12Juker

Mac Points: 56.158, Nivel: 24Subir Nivel: 73%, 1.292 MacPoints Actividad en Applesana: 71% Ingreso:mar 2006 .:98

godisnotalive ya he probado esa grafica ( la Nvidia 8800 ) y alguna mas en mi equipo y va divina de la muerte

Pero las he devuelto junto a las placas base.
No me gusta tener algo que aun no he pagado por muy amigo que sea el OEM.

Y si, con los kext oficiales que hay en el wiki applesana que vienen de Mac OS X 10.5.2.
Lo unico que tienen esos kext es que estan empaquetados.godisnotaliveLibrepensador

Ingreso:sep 2007Ubicación:Valencia .:14

has visto la placa? Basicamente es como la tuya solo que lleva 2 PCI Express 2.0 y chipset X38 sin grafica integrada, me mola bastante la placa.
Has probado alguna similar con kalyway, vanilla kernel y efi?godisnotaliveLibrepensador

Ingreso:sep 2007Ubicación:Valencia .:14

y esta graficas? Es un modelo que me gusta particularmente
juker12Juker

Mac Points: 56.158, Nivel: 24Subir Nivel: 73%, 1.292 MacPoints Actividad en Applesana: 71% Ingreso:mar 2006 .:98

Miliuco yo no he seguido tu tutorial ni tampoco los drivers del wiki

Lo hecho a mi modo y veo los 512MB y core image y quart extreme activado pero......



Solo en Mac OS X 10.5.1 por que en la actualizacion 10.5.2 mas actualizacion de graficos 1.0 no puedo...de momento

Parece que la actualizacion de graficos tiene mas chica de lo que yo pensaba.
Con esta ultima actualizacion la muy joia da casi 75 puntos mas en OpenGL pero pillo sombras negras

asi que a investigar

Bueno...pues sigo pelando que soy mas torpe que todoImágenes Adjuntasatix1600_osx86.jpg (61,1 KB, 380 visitas)miliucoLazarus Long

Mac Points: 18.376, Nivel: 14Subir Nivel: 53%, 1.274 MacPoints Actividad en Applesana: 0% Ingreso:mar 2006Ubicación:La Robla, León (ES) .:44

¿Ya llegó, Juker? No la llegué a probar en Leopard pero en Tiger iba muy bien, sin artefactos. Como a ti te gusta hacerlo por ti mismo, supongo que no pararás hasta que encuentres la manera de que vaya OK. Pero si deseas probar algo sencillo, en el hilo en que se habla del método MacLovin en el foro pitinglis, cuyo título es
"[Guide] ATI x1x00 Video Cards on Leopard, QE/CI Enabled"
se puede descargar un instalador ya preparado para varios ID de esta tarjeta, creo recordar que era 71c1 (también lo veo ahora en la imagen que has posteado) , descarga ése y a ver si funciona.

Yo, por si acaso, no he puesto la actualización de gráficos (es la única actualización que tengo sin instalar) porque me convenció tu argumento de para qué tipo de Mac estaba diseñada sobre todo, la verdad es que con Natit cogido del canal #RadeonHD en el IRC de Netkas va perfecta, mejor que con Triakis (no sé por qué pues son drivers muy parecidos).

Todavía no tengo la 8800GT 512, en cuanto la pruebe lo comentaré, supogo que Leopard no la reconocerá sin más y que tendré que instalar los drivers de 10.5.2 que hay en el wiki, ¿no?.

Todo sobre Apple, Mac e Iphone