Civilization IV Warlords extension pack for Mac OS X Leopard &, Snow Leopard compatible!

Civilization IV Warlords extension pack for Mac OS X Leopard &, Snow Leopard compatible!

yandy Applesan@

Ingreso: oct 2009 Nº Usuario:72651 Karma: 10

Civilization IV Warlords extension pack for Mac OS X Leopard & Snow Leopard compatible!


Civilization IV Warlords extension pack for Mac OS X
Leopard & Snow Leopard compatible!




About Civilization IV: Warlords
The first expansion pack for the Firaxis Games’ award-winning title, Civilization IV. Paying homage to some of history’s greatest military

leaders, the expansion delivers eight unique and interesting scenarios, giving players the chance to change the course of history with the

help of their new powerful allies.

Genre: Strategy

System Requirements:

Mac OS X 10.3.9 or later
Mac OS X 10.4.6 or higher recommended
1.8GHz PowerPC G5 or Intel processor (2GHz or higher recommended)
512MB of RAM, 64MB video RAM (128MB recommended, ATI Radeon 9600 or Nvidia GeForce FX 5200 or better)
3.5GB hard disk space
Internet (TCP/IP) and LAN (TCP/IP) play supported. Internet play requires broadband connection.

Download:
[Leopard_&_Snow_Leopard_compatible].part01.rar.html
[Leopard_&_Snow_Leopard_compatible].part02.rar.html
[Leopard_&_Snow_Leopard_compatible].part03.rar.html
[Leopard_&_Snow_Leopard_compatible].part04.rar.html
[Leopard_&_Snow_Leopard_compatible].part05.rar.html
[Leopard_&_Snow_Leopard_compatible].part06.rar.html
[Leopard_&_Snow_Leopard_compatible].part07.rar.html
[Leopard_&_Snow_Leopard_compatible].part08.rar.html
[Leopard_&_Snow_Leopard_compatible].part09.rar.html
[Leopard_&_Snow_Leopard_compatible].part10.rar.html
[Leopard_&_Snow_Leopard_compatible].part11.rar.html
-----------------------------------------
DON'T FORGET SAY THANKS!!
,) FoxGuilian Applesan@

Ingreso: dic 2009 Ubicación: Calzoncillos Nº Usuario:76641 Karma: 9

si funciona eres mi dios!!

Gracias tio gracias!!

RELACCIONADO CON Civilization IV Warlords extension pack for Mac OS X Leopard &, Snow Leopard compatible!